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INTRODUCTION 

La carte microcontrôleur Gamel Trophy est utilisée en projet de premier semestre et en TP d’informatique 

industrielle à l’IUT. Elle est aussi le support de TP d’informatique industrielle en licence professionnelle et en 

école d'ingénieur IFIPS. 

 

Elle est réalisée autour d’un microcontrôleur Microchip PIC18F4550. Ce microcontrôleur 8 bits est issu d’une 

famille très répandue : 2 milliards d’exemplaires vendus par Microchip, 1er fabricant mondial de 

microcontrôleurs 8 bits. 

De tels microcontrôleurs sont employés dans l’informatique embarquée des automobiles, de 

l’électroménager, des télécoms et des systèmes industriels. Ainsi, vous trouverez des microcontrôleurs 

Microchip entre autres dans les autos BMW ou Toyota, les magnétoscopes JVC, les consoles SEGA, les 

téléphones Motorola ou Nokia, les systèmes automatisés AllenBradley ou Honeywell. 

 

Dans la gamme de Microchip, le microcontrôleur PIC18F4550 fut choisi pour les raisons suivantes : 

� Issu de la famille 18Fxxx, c’est un microcontrôleur rapide (jusqu’à 12 MIPS), possédant des convertisseurs 

analogiques numériques, des sorties PWM, une liaison série USART, une liaison I2C, une liaison SPI et 4 

timers. 

� Il comprend un périphérique USB. L'utilisation de la connexion USB permet d'alimenter la carte 

microcontrôleur par le bus USB et de le programmer avec un bootloader, ce qui évite d'avoir à utiliser un 

programmateur. 

� Il est disponible en boîtier DIP, ce qui facilite la conception de la carte et le remplacement du 

microcontrôleur en cas de panne. 

� Les outils de développement fournis par Microchip sont fiables, relativement bon marché, puissants et 

faciles à utiliser. 

 

Nous utiliserons les outils de développement suivants : 

� Environnement de développement MPLAB IDE v7.40 

� Compilateur C MPLAB C18 Compiler v3.0 

� Programmateur / Débogueur MPLAB ICD2 

 

Ce guide de mise en œuvre vous présente les différents périphériques internes ou externes disponibles sur 

la carte et les fonctions permettant de les utiliser. Vous y trouverez aussi un tutorial pour l'utilisation de la 

chaîne de développement. 
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2 CARACTERISTIQUES GENERALES 

2.1 ALIMENTATION 

Vous pouvez alimenter la carte avec une alimentation externe ou à partir du bus USB. Une led rouge indique 

le bon fonctionnement de l’alimentation 5 V. 

� L'alimentation externe est une tension continue supérieure à 8 V (jusqu’à 18 V). Cette tension est ensuite 

régulée pour fournir 5 V au microcontrôleur et aux différents périphériques. Typiquement la carte consomme 

50 mA.  

� Le bus USB fournit une tension de 5 V. Cette tension est moins précise que celle en sortie du régulateur. 

2.2 PROGRAMMATION 

On programme le microcontrôleur par le connecteur RJ12 présent à côté du bouton Reset. Il est relié aux 

broches MCLR, PGC et PGD pour la programmation et le débogage (mode pas-à-pas, lecture des variables 

pendant le fonctionnement,…). Cf chapitre  10. Un bouton Reset permet, en mode autonome, de redémarrer 

le programme. Son état n’est pas disponible pour une utilisation par votre programme. 

 

Les outils permettant de programmer cette carte, MPLAB IDE et MPLAB C18 Compiler (version sans 

optimisation) ainsi que de nombreux documents sont disponibles sur le site de Microchip 

(www.microchip.com). Les documents réalisés à l'IUT (tutorial, schéma de la carte, librairies…) sont 

disponibles dans le dossier Y:\commun\Microchip. 

2.3 PERIPHERIQUES INTERNES DU MICROCONTROLEUR 

La carte microcontrôleur est équipée d’un microcontrôleur PIC18F4550 ayant comme périphériques 

internes : 

� 4 timers. Certains timers peuvent être utilisés comme compteurs rapides avec une horloge externe. 

Deux entrées compteur rapide sont disponibles sur le connecteur I/O (T0CKI et T13CKI). cf chapitre  7 pour 

la mise en œuvre du timer1. 

� Un convertisseur analogique/numérique 10 bits. 7 entrées analogiques sont disponibles sur le 

connecteur I/O et une entrée analogique est reliée au potentiomètre AN0. cf chapitre  7 pour leur mise en 

œuvre. 

� Deux sorties PWM associées au timer2. Elles sont disponibles sur le connecteur I/O. cf chapitre  7 pour 

leur mise en œuvre. 

� Une liaison série USART disponible sur le connecteur RJ9 série. Attention, pour simplifier la carte, cette 

liaison série est en niveaux logiques 0-5V. Si on veut utiliser le format RS232 (niveaux logiques +12V et -

12V), il faut donc utiliser un câble adaptant les niveaux des signaux. cf chapitre  9 pour la mise en œuvre de 

cette liaison. 

� Une liaison I2C disponible sur le connecteur 4 points. cf chapitre  9 pour la mise en œuvre de la liaison. 

� Une liaison USB disponible sur le connecteur USB B. 
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De plus, 3 interruptions externes sont disponibles sur le connecteur I/O, une liaison SPI, un oscillateur 

interne. cf documentation Microchip pour leur mise en œuvre. 

Le microcontrôleur dispose pour les données d’une mémoire RAM (rapide, mais volatile, 2 Ko Octets) et 

d’une mémoire EEPROM (non volatile mais très lente en écriture, 256 Octets). La mémoire programme quant 

à elle est une mémoire Flash (non volatile, 32 Ko, soit 16384 instructions). 

2.4 PERIPHERIQUES EXTERNES 

Sur la carte, ont été ajoutés les périphériques externes suivants : 

� Un afficheur LCD 2x16 caractères alphanumériques câblé sur le port D, avec son potentiomètre de 

contraste. Cf chapitre  6 pour sa mise en œuvre. 

� 3 boutons poussoirs BP0, BP1 et BP2 câblés sur les entrées Tout ou Rien B3, B4 et B5 du 

microcontrôleur. Cf chapitre  5 pour leur mise en œuvre. 

� Un potentiomètre délivrant une tension de 0 à 5V câblé sur l’entrée analogique AN0 du 

microcontrôleur. Cf chapitre  5 pour sa mise en œuvre. 

� Une led verte est connectée à la sortie Tout ou Rien A6 du microcontrôleur. Cf chapitre  5 pour sa mise 

en œuvre. 

 

Sur la carte, un oscillateur à 20 MHz dont la fréquence est multipliée en interne permet d'utiliser l'USB Full 

Speed (nécessité d'une fréquence d'horloge à 96 MHz pour un transfert à 12 Mbps théorique). Avec les 

paramètres par défaut de la carte (inclus dans gamelinit_v3.h), le fonctionnement du cœur du 

microcontrôleur est cadencé à 48 MHz (un cycle instruction nécessite 4 tops horloge donc 83.3 ns). 
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3 SCHEMAS 

Les schémas présentés ici sont issus d’un projet Protel DXP disponible dans le dossier 

Y:\commun\Microchip\Carte_Micro_Gamel_Trophy. 

 

3.1 SCHEMA D’IMPLANTATION DES COMPOSANTS 
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4 PROGRAMMATION DE LA CARTE – GENERALITES 

Ce chapitre vous présente les quelques connaissances indispensables avant de commencer un programme. 

4.1 CONFIGURATION DU MICROCONTROLEUR 

Pour s'adapter au mieux aux différentes applications auxquelles est destiné le microcontrôleur PIC18F4550, 

notamment en terme de consommation d'énergie, de nombreuses configurations sont possibles. Vous est 

présentée ici une configuration de base, largement suffisante pour la majorité des applications. Les curieux 

pourront trouver plus d'informations sur les configurations dans la datasheet du PIC18F4550. 

Une partie de la configuration se fait en ROM, c'est-à-dire dans une zone non modifiable par le programme. 

Pour écrire dans cette zone particulière, on insère les instructions de configuration après le mots-clé suivant 

: #pragma config. Les différentes valeurs que peuvent prendre les registres de configuration sont indiquées 

dans le document c18_config_settings.pdf. 

Pour simplifier la création d'un projet, la configuration par défaut (horloge interne à 48 MHz, A6 en sortie, 

mode debug,…) peut être faite en incluant l'en-tête gamelinit_v3.h à votre projet. 

#include "gamelinit_v3.h" 

 

D'autres étapes de configuration se font en début d'exécution du programme, dans des zones de mémoire 

accessibles en écriture. Cette configuration se fait juste après les déclarations/définitions des variables. 

Vous y mettrez la configuration des entrées/sorties et les initialisations de périphériques (lcd_init(),…  

void main() 
{ 
char…  // déclaration/définition des variables 
lcd_init(); 
… 
} 

4.2 CONFIGURATION DES ENTREES/SORTIES TOUT OU RIEN 

En plus de la configuration des périphériques internes et externes, en début de programme et parfois 

pendant le programme, vous aurez à configurer aussi les entrées et sorties Tout ou Rien. 

Pour cela, on utilise la fonction TRISx où x est le nom du port. Un bit à 0 correspond à la broche en sortie et 

un bit à 1 à la broche en entrée. 

Exemple pour le PORTA. 

RA7 RA6 RA5 RA4 RA3 RA2 RA1 RA0 

 

Si on veut placer RA6 en sortie (broche reliée à la Led verte), il faut mettre le bit 6 de TRISA à 0. 2 

méthodes pour cela : 

� soit on travaille avec un bit : 

TRISAbits.TRISA6 = 0; 

� soit on travaille avec des masques, surtout si on a plusieurs broches à configurer, sans changer l'état des 

autres bits : 

TRISA = TRISA & 0b10111111; 
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5 BOUTONS, POTENTIOMETRE ET LED 

Pour les TPs et projets, la carte dispose d’une très modeste interface homme-machine composée de 3 

boutons poussoirs, d’un potentiomètre en entrée et d’une Led et d’un afficheur LCD en sortie. 

5.1 BOUTONS POUSSOIRS 

Comme indiqué sur le schéma du chapitre 3, Les boutons poussoirs sont câblés de la manière suivante : 

VCC

GND

Vers microcontrôleur4,
7 

kO
hm

s
BPx

 

Lorsque le bouton n’est pas enfoncé, il se comporte comme un interrupteur ouvert. Grâce à la résistance de 

pull-up, le signal reçu par le microcontrôleur sera VCC, ici 5V. Les entrées du microcontrôleur n’absorbant 

pas de courant, la résistance n’est parcourue par aucun courant. 

Lorsque le bouton est enfoncé, il se comporte comme un interrupteur fermé, reliant ainsi la masse à l’entrée 

du microcontrôleur qui reçoit alors 0V. La résistance de pull-up est parcourue par un courant VCC/R. 

Les boutons sont connectés aux broches suivantes 

- BP0 B3 

- BP1 B4 

- BP2 B5 

 

Exemple pour lire l’état d’un bouton poussoir (par exemple BP0) 

char BP0=0 ; 
TRISB = TRISB | 0x0x04; //configuration en entrée d e RB3 
BP0 = PORTBbits.RB3 ; //lecture de l’état logique d e B3 

 

Pour lire plusieurs boutons à la fois, il est plus intéressant d’utiliser des masques (cf cours II1). 

Un changement d’état sur B4 ou B5 peut-être configuré pour provoquer une interruption. 

5.2 POTENTIOMETRE 

A côté des boutons poussoirs, on trouve un potentiomètre relié à l’entrée analogique AN0 (occupant la 

broche relié à l’entrée Tout ou Rien RA0). Il est câblé de la manière suivante. 

VCC

GND

Vers microcontrôleur

4,
7 

kO
hm

s
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L’entrée du microcontrôleur n’absorbant pas de courant, le montage est un simple diviseur de tension. Pour 

une position alpha du curseur du potentiomètre, l’entrée analogique du microcontrôleur peut donc lire la 

tension suivante :  

Vmicrocontrôleur = alpha.VCC=alpha x 5 Volts 

La lecture de la valeur du potentiomètre utilise le convertisseur analogique numérique 10 bits. Pour plus de 

détails, on se référera au chapitre  7 qui traite de la librairie associée au convertisseur ADC interne.  

 

Exemple pour la lecture de la valeur du potentiomètre. 

#include "gameladc_v3.h" 
... 

int potana=0 ; 
adc_init(0) ;  //initialisation du convertisseur 
potana = adc_read(0) ; //lecture de la valeur AN0 

5.3 LED 

Une led verte, appelée led_A6, est relié à la sortie Tout ou Rien A6 du microcontrôleur. Elle est câblée de la 

manière suivante : 

GND

Depuis microcontrôleur A6
68

0 
O

hm
s

Le
d

V
er

te

 

Si A6 = 1, le microcontrôleur impose 5 V en sortie, le courant passe alors dans la résistance et la diode Led : 

la diode s’allume. La résistance impose un courant ID = (VCC-VD)/R = 5 mA. C’est le microcontrôleur qui 

fournit le courant nécessaire. Une sortie Tout ou Rien peut fournir jusqu’à 25 mA. 

Si A6 = 0, le microcontrôleur impose 0V, la led est alors éteinte 

Allumer la led_A6 revient ainsi à modifier l’état logique de A6. 

 

Exemple pour allumer la led_A6 

TRISA = TRISA & 0xBF ; //configuration en sortie de  RA6 
PORTAbits.RA6 = 1 ; //Mise à 1 de RA6 
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6 AFFICHEUR LCD 

Mieux que la Led_A6, vous pouvez utilisez l’afficheur LCD pour envoyer des informations du microcontrôleur 

à l’utilisateur. Il est câblé sur le port D, comme indiqué sur le schéma du chapitre 3. L’afficheur LCD est doté 

de son propre contrôleur qui interprète les instructions du microcontrôleur. Un protocole de dialogue est 

établi par le fabricant du contrôleur de l’afficheur LCD. 

Pour simplifier le travail du programmeur, une librairie regroupe les fonctions les plus utiles : gamelcd_v3 : 

 

void lcd_init(void) : Cette fonction initialise l'afficheur. Il faut absolument l’appeler dans votre programme 

avant tout emploi d’une autre fonction de la librairie. Une seule exécution de cette fonction est suffisante. 

 

void lcd_gotoyx(char y, char x) : Cette fonction positionne le curseur sur l’afficheur. y correspond à la 

ligne, x à la colonne et (1,1) est le coin haut gauche. Au prochain appel d’une fonction d’affichage lcd_put…, 

le premier caractère s’inscrira à l’endroit désigné par lcd_gotoyx. 

 

void lcd_puti(int nombre) : Cette fonction affiche un nombre entier (int) sur l’afficheur 

 

void lcd_putc(char lettre) : Cette fonction affiche un caractère sur l’afficheur 

 

void lcd_puts(char* message) : Cette fonction affiche la chaîne de caractères (string) située en mémoire 

RAM (mémoire donnée) désignée par le pointeur message. Le message doit d'abord être stockée dans une 

variable (située en mémoire donnée). 

 

void lcd_putrs(const rom char* message) : Cette fonction affiche la chaîne de caractères (string) 

située en Flash (mémoire programme) désignée par le pointeur message (d'où le type const rom char) 

 

Pour utiliser la librairie, vous devez inclure en en-tête de votre fichier principal les déclarations de ces 

différentes fonctions. Ceci est fait par l'instruction #include gamelcd_v3.h. 

 

Exemple pour l’affichage de "arthur" en bas à droite de l’écran. 

� Avec la chaîne de caractères stockée dans la mémoire flash : 

#include "gamelcd_v3.h" 
... 

lcd_init();  // initialisation de l’afficheur 
lcd_gotoyx(2,10); //déplacement du curseur 
lcd_putrs("arthur"); //écriture du texte 
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� Avec la chaîne de caractères stockée dans la mémoire RAM 

#include "gamelcd_v3.h" 
... 

char texte[]="arthur"; //définition d'une chaîne de   
     //caractères en RAM. 
lcd_init();  // initialisation de l’afficheur 
lcd_gotoyx(2,10); //déplacement du curseur 
lcd_puts(texte); //écriture du texte 

 

Remarques 

� Les fonctions lcd_putc, lcd_putrs et lcd_puts comprennent les caractères spéciaux suivant : 

- \n pour passer à la ligne 

- \f pour effacer 

- \b pour reculer d'une case 

� Pour afficher la valeur d’un nombre entier de 8 bits (type char), il faut d’abord le transformer en entier de 

16 bits (type int). Pour cela, on fait ce qu’on appelle un cast, en rajoutant entre parenthèse le type nouveau 

voulu. Cela a pour effet de créer un int n’ayant que des 0 dans l’octet de poids fort. 

 

Exemple de syntaxe : 

char arthur=10 ; 
… 
lcd_puti( (int)arthur ) 

 

� L’écriture sur l’afficheur LCD est une opération relativement lente. L’initialisation prend 25 ms et l’écriture 

d’un caractère 100 µs environ (à comparer avec les 0,1 µs que dure l’exécution d’une instruction simple.). Il 

faut en tenir compte si votre programme doit effectuer une tâche rapidement ou à une cadence fixe 

(asservissement, tâche d’interruption). 

Dans la source de la librairie gamelcd_v3.c, vous pouvez lire comment ces fonctions sont écrites en C et 

ainsi regarder quel dialogue s’établit entre le microcontrôleur et l’afficheur LCD. 
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7 LES PERIPHERIQUES INTERNES 

Le microcontrôleur PIC18F4550 a de multiples périphériques internes. Dans ce chapitre, nous vous 

présentons les 3 périphériques internes les plus utilisés : le convertisseur analogique, les sorties PWM et les 

timers.  

Les périphériques de communication sont étudiés au chapitre  9. 

7.1 LE CONVERTISSEUR ANALOGIQUE 

Le PIC18F4550 est muni en interne d'un convertisseur analogique numérique 10 bits. Par multiplexage, 

celui-ci peut vous renvoyer jusqu'à 13 nombres images des tensions analogiques présentes sur différentes 

broches du boîtier. Vous pouvez utiliser celles qui sont disponibles sur le connecteur I/O : AN1 à AN7. La 

première, AN0, est reliée au potentiomètre nommé AN0. 

Pour utiliser le convertisseur simplement, une librairie, gameladc_v3, regroupe les fonctions dont vous avez 

besoin : 

 

void adc_init(char numero_lastchannel_used) est une fonction qui initialise le convertisseur 

analogique numérique (temps d'acquisition et temps de conversion). Vous pouvez utiliser le nombre 

d'entrées analogiques que vous souhaitez, à condition de les prendre successives, à partir de AN0 et de 

donner en paramètre de la fonction adc_init le numéro du dernier "channel" que vous utilisez. 

 

int adc_read(char numero_channel) est une fonction qui déclenche la lecture de la valeur analogique 

présente au "channel" indiqué en paramètre. Elle renvoit ensuite cette valeur sous forme d'entier 16 bits. 

Seuls les 10 derniers bits sont significatifs. 

L'utilisation de la librairie demande que soit inclus en-tête de votre fichier source le fichier de déclaration de 

ces fonctions, gameladc.h 

 

Exemple effectuant la lecture de la valeur du potentiomètre AN0 (relié à AN0) et la stockant dans un entier. 

#include "gameladc_v3.h" 
… 
void main(void) 
{ 
 int potana = 0; //définition de potana 
 adc_init(0);    //initialisation du convertisseur 
 while(1) 
  potana = adc_read(0); //lecture de AN0 
} 

 

Remarques 

� L'acquisition suivie de la conversion durent environ 16 µs, un temps relativement grand comparé au 83 ns 

nécessaire à l'exécution d'une instruction simple. 

 

� La librairie donnée ne vous permet pas de passer d'une entrée configurée en analogique à une entrée 

configurée en Tout ou Rien en cours de programme, elle ne vous permet pas non plus d'utiliser les 
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interruptions, ou de modifier les temps d'acquisition, les références…. Vous trouverez toutes les 

caractéristiques du convertisseur et le rôle de chaque registre le concernant au chapitre 19 de la datasheet 

et des librairies plus complètes et plus complexes dans le chapitre 2.2 du guide d'utilisation des librairies 

MPLAB_C18_librairies.pdf. 

7.2 LES PWMS 

Le PIC18F4550 est muni en interne de deux blocs générant des PWMs, nommées PWM1 et PWM2. La PWM 

(pulse width modulation) est un signal carré dont le rapport cyclique (rapport entre la durée du niveau haut 

et la période du signal) peut varier. C'est un signal très utilisé dans la commande de moteur ou la conversion 

numérique/analogique. 

Les blocs PWMs utilisent pour fonctionner le timer2. 

 

pwm(t)

t

5V

période T

dutycycle dc
 

 

Pour utiliser les sorties PWM présentes aux broches C2 (PWM1) et C1 (PWM2), vous utiliserez la librairie 

gamelpwm_v3 qui regroupe les fonctions dont vous avez besoin. 

 

void pwm_init(char period, char nb_canaux) est une fonction qui initialise les sorties PWM. Si 

nb_canaux = 2 alors les deux sorties sont activées, sinon seule la sortie PWM1 est activée. Vous entrerez en 

paramètre de cette fonction la période de votre PWM, en nombre de pas de 333 ns. period est un entier de 

8 bits. C'est cette fonction qui configure le timer2 pour le fonctionnement des PWMs. 

 

void pwm_setdc1(unsigned int dutycycle1) définit le rapport cyclique de PWM1 

 

void pwm_setdc2(unsigned int dutycycle2) définit le rapport cyclique de PWM2 

dutycycle est le temps pendant lequel PWM est haut, en nombre de pas de 83,3 ns. dutycycle est un entier 

de 10 bits. 

 

L'utilisation de la librairie demande que soit inclus en-tête de votre fichier source le fichier de déclaration de 

ces fonctions, gamelpwm_v3.h. 
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Exemple permettant de sortir en C1 et C2 deux PWMs à 20 kHz, de rapport cyclique moitié. 

#include gamelpwm.h 
... 
void main(void) 
{ 
 pwm_init(150,2);  //initialisation de la periode 5 0 
    //µs, pour les deux canaux 
 pwm_setdc1(300); //définition du temps à niveau 
 pwm_setdc2(300);  //haut(dutycycle) : 25 µs 
} 

Remarque : 

� Les broches configurées en PWM par pwm_init(...) restent en PWM tout le programme. 

� Attention : la période a une résolution de 333 ns et dutycycle une résolution de 83,3 ns. 

� Si le temps à niveau haut (dutycycle x 83,3 ns) est supérieur à la période (period x 333 ns) alors la pwm 

est toujours à 1 (rapport cyclique maximum de 100%). 

7.3 TIMERS 

Le PIC18F4550 comporte 4 timers (de timer0 à timer3), de 8 ou 16 bits (seul le timer2 est un timer 8 bits). 

Un timer est en fait un compteur que l'on peut connecter à l'horloge interne du µC : il compte alors le 

nombre de cycle instructions (un cycle instructions dure 83,3 ns). Les timers 0 et 1 peuvent aussi être 

connectés à une horloge externe (reliée via les broches T0CKI et T1CKI) : ils comptent dans ce cas le 

nombre d'occurrence d'un événement (front montant ou front descendant) se produisant sur cette broche. 

Un timer 16 bits peut compter de 0 à 65535 (216-1). Pour compter un nombre plus important d'événements, 

on compte de 2 en 2, de 4 en 4, de 8 en 8… ce coefficient de prédivision de l'horloge est appelé préscalaire. 

 

Le fonctionnement des timers est expliqué en détail dans la datasheet du microcontrôleur (ch 11 à 14) et 

Microchip fournit des librairies permettant d'utiliser ces timers. Pour utiliser ces librairies, consultez le 

document MPLAB_C18_Libraries.pdf et incluez le fichier d'en-tête timers.h. (On mettra des <> pour indiquer 

au compilateur que ce fichier est dans le dossier des librairies du compilateur et non dans votre dossier de 

travail.) 

 

Voici quelques mots pour expliquer l'utilisation du timer 0 avec la librairie timers. 

 

void OpenTimer0( unsigned char config ) Cette fonction permet de lancer le timer et de le configurer. 

Le paramètre de configuration est une association de différents masques validant chacun une 

caractéristique : 
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Enable Timer0 Interrupt: TIMER_INT_OFF pour ne pas utiliser les interruptions 
TIMER_INT_ON Interrupt enabled 
TIMER_INT_OFF Interrupt disabled 
Timer Width: T0_16BIT pour utiliser le mode 16 bits du timer 
T0_8BIT 8-bit mode 
T0_16BIT 16-bit mode 
Clock Source: Permet de sélectionner l'horloge du timer (horloge interne ou TxCKI) 
T0_SOURCE_EXT External clock source (I/O pin) 
T0_SOURCE_INT Internal clock source (TOSC) 
External Clock Trigger : T0_EDGE_RISE pour compter les fronts montants 
T0_EDGE_FALL External clock on falling edge 
T0_EDGE_RISE External clock on rising edge 
Prescale Value: Permet de choisir le préscalaire. 
T0_PS_1_1 1:1 prescale 
T0_PS_1_2 1:2 prescale 
T0_PS_1_4 1:4 prescale 
T0_PS_1_8 1:8 prescale 
T0_PS_1_16 1:16 prescale 
T0_PS_1_32 1:32 prescale 
T0_PS_1_64 1:64 prescale 
T0_PS_1_128 1:128 prescale 
T0_PS_1_256 1:256 prescale 

 

void WriteTimer0( unsigned int timer ); Cette fonction permet d'écrire la valeur timer dans le timer. Ce 

dernier recommencera alors à compter, à partir de cette valeur. 

 

unsigned int ReadTimer0( void )  Cette fonction permet de lire la valeur actuelle du timer. 

 

Exemple de programme permettant de faire clignoter une led avec une période de 0,5 s. 

#include <p18f4550.h> 
#include "gamelinit_v3_bootloader.h" 
#include "timers.h" 
 
void main(void) 
{ 
 TRISA = 0xBF; 
 OpenTimer0( TIMER_INT_OFF & 
   T0_16BIT & 
   T0_SOURCE_INT & 
   T0_PS_1_128 ); //config timer 
 while(1) 
 { 
  WriteTimer0(0); 
  while(ReadTimer0()<46893); //attente 0.5ms 
  PORTAbits.RA6 = !PORTAbits.RA6; //inverse led 
 } //end while 
} //end main 
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8 CONNECTEUR I/O 

Ce connecteur regroupe l'ensemble des entrées/sorties disponibles du microcontrôleur. Voici le plan du 

connecteur : 

VDD Out 1 2 GND 
AN2 ou RA2 3 4 AN1 ou RA1 

RB2 ou INT2 ou AN8 5 6 AN3 ou RA3 
RB1 ou INT1  7 8 RA4 ou T0CKI 
RB0 ou INT0  9 10 AN4 ou RA5 
AN6 ou RE1 11 12 AN5 ou RE0 

T13CKI ou RC0 13 14 AN7 ou RE2 
PWM1 ou RC2 15 16 PWM2 ou RC1 

 

1 La broche 1 permet de fournir une alimentation de 5V à une autre carte avec un courant 
limité (moins de 50 mA). Si la carte que vous désirez connecter à la carte microcontrôleur 
est alimentée directement par la batterie, il ne faut surtout pas utiliser cette broche du 
connecteur. 

2 La broche 2 est la masse. Si la carte que vous désirez connecter à la carte microcontrôleur 
est alimentée directement par la même batterie que la carte microcontrôleur, les masses 
sont reliées via la masse de la batterie. Il est alors déconseillé de relier une nouvelle fois 
les masses via le connecteur. 

3, 4, 6, 
10, 11, 
12, 14 

Ces broches du connecteur sont reliées à des broches du microcontrôleur qui peuvent être 
configurées individuellement comme des entrées analogiques ou comme des 
entrées/sorties Tout ou Rien. Par défaut, ce sont des entrées analogiques du 
microcontrôleur. 

5 Cette broche du connecteur est reliée à une broche du microcontrôleur qui peut être au 
choix configurée comme une entrée analogique (c'est le cas par défaut), comme une 
entrée interruption (vous verrez cela plus tard) ou comme un entrée/sortie Tout ou Rien. 

7 et 9 Ces broches sont reliées à des entrées/sorties Tout ou Rien du microcontrôleur (attention, 
il faut pour cela avoir configuré les entrées analogiques). Elles peuvent servir d'entrées 
d'interruption. Attention, on ne peut utiliser ces deux broches en même temps que le bus 
I2C. 

8 Cette broche est reliée à une broche du microcontrôleur qui peut être configurée au choix 
comme une entrée/sortie Tout ou Rien ou comme entrée comptage rapide du 
compteur/timer 0. 

13 Cette broche est reliée à une broche du microcontrôleur qui peut être configurée au choix 
comme une entrée/sortie Tout ou Rien ou comme entrée comptage rapide des 
compteurs/timers 1 et 3. 

15 et 
16 

Ces broches sont reliées à des broches du microcontrôleur qui peuvent être configurées au 
choix comme des entrées/sorties Tout ou Rien ou comme sortie PWM (Pulse Width 
Modulation ou Modulation de Largeur d'impulsion) des blocs PWM 1 et 2. 

 

Attention, sur le schéma de la carte (chapitre 3), vous pouvez voir que les entrées/sorties reliées au 

connecteur sont protégées par des résistances de 680 Ohms. Tant qu'il n'y a pas de courant fourni ou 

absorbé par le microcontrôleur (c'est le cas quand la broche est configurée comme entrée du 

microcontrôleur), cela ne modifie rien. Par contre, si vous voulez que le microcontrôleur fournisse du courant 

(allumage d'une diode led), il vous faudra tenir compte de la chute de tension dans cette résistance. 

Une sortie du microcontrôleur peut fournir jusqu'à 25 mA mais, toutes sorties comprises, le microcontrôleur 

ne peut fournir que 200 mA. 
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9 PERIPHERIQUES DE COMMUNICATION 

9.1 PORT SERIE RS232 

La liaison RS232 est une liaison série (les bits sont envoyés les uns après les autres) asynchrone (l'horloge 

cadençant la liaison n'est pas transmise.) 

Le port série de la carte µC, présent sur le connecteur RJ9 est en niveaux logiques 0 / 5V. Il ne peut donc 

pas être connecté tel quel à une liaison RS232 de PC (niveaux logiques +12V / -12V). Pour ce faire, il faudra 

utiliser un câble adapté. Ils sont disponibles au magasin. 

 

On utilise les fonctions de la bibliothèque C18 pour établir une communication RS232 : 

openUSART 

putcUSART 

putsUSART ou putrsUSART 

getcUSART 

getsUSART 

BusyUSART 

DataRdyUSART 

Référez-vous à la documentation de la librairie pour comprendre comment les utiliser. (cf Ch  12) 

9.2 PORT I2C 

Les liaisons SPI et I2C sont des liaisons séries synchrones : les bits sont envoyés les uns après les autres sur 

un même fil. Un autre fil sert à transmettre l'horloge cadençant la transmission. L'horloge étant ainsi 

imposée exactement pour tous, on peut autoriser des débits bien supérieurs à ceux d'une liaison série 

asynchrone. 

La liaison I2C est de plus un bus, c'est-à-dire qu'il permet de relier plus que 2 périphériques entre eux 

(jusqu'à 127). 

 

Pour utiliser la liaison I2C, on utilise la bibliothèque C18. Référez-vous à la documentation de la librairie pour 

comprendre comment les utiliser. (cf Ch  12) 

9.3 PORT USB 

Le microcontrôleur PIC18F4550 est aussi muni d'un périphérique USB qui permet de communiquer avec le 

PC. Ce port permet notamment de programmer la carte à l'aide du bootloader. Son utilisation pour 

communiquer avec le PC est plus complexe. Le mode liaison série virtuelle (Classe CDC du protocole USB) 

est le plus simple à mettre en œuvre. Plus d'informations sont disponibles sur la note d'application AN956 de 

Microchip. (cf site Web de Microchip). 
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10 TUTORIAL OUTILS DE DEVELOPPEMENT 

Pour développer des applications pour les microcontrôleurs Microchip, divers outils de développement sont 

possibles, fournis par Microchip ou par des sociétés tiers. 

 

Nous utiliserons les outils de développement suivants : 

� Environnement de développement MPLAB IDE v7.50 

� Compilateur C MPLAB C18 Compiler version 3.0 

� Programmateur / Débogueur MPLAB ICD2 

 

Pour développer sous MPLAB, vous devez impérativement créer un projet, en suivant la démarche ci-

dessous. 

Un projet regroupe un fichier contenant le programme principal (main), des bibliothèques à compiler, le tout 

associé à des bibliothèques du compilateur. Vous aurez aussi à rajouter à votre projet le fichier linker, 

indiquant notamment l'emplacement de votre programme et de vos données en mémoire. 

10.1 CREATION D’UN PROJET ET CONFIGURATION DE MPLAB 

Etape 1 : Créer un dossier, y ajouter les librairies IUT 

Sur le disque local (E:\), créez un dossier associé à votre projet. Copiez dans ce dossier les librairies que 

vous souhaitez utiliser (vous les trouverez dans le répertoire Y:\commun\Microchip\Librairies IUT.), ainsi que 

le fichier de configuration gamelinit_v3.h. 

En fin de séance, vous recopierez bien sûr votre dossier-projet dans votre répertoire personnel (sur U:\). 

Etape 2 : Création du projet 

Sélectionnez Project>Project Wizard pour créer un nouveau projet. Cliquez sur suivant. Ensuite choisissez 

votre microcontrôleur, appelé ici device (composant) ou parfois target (cible). Le microcontrôleur de votre 

carte est un 18f4550. 
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Ensuite cliquez sur suivant. Vous devez choisir ici quel compilateur C vous souhaitez utiliser. Dans le menu 

déroulant, choisissez Microchip C18 Toolsuite. Dans la fenêtre Toolsuite Contents, vous trouverez tous les 

éléments du compilateur. Pour chaque élément, vous devez indiquer son emplacement sur le disque. Sur les 

PCs de salle de projet, vérifiez que les emplacements sont les suivants : 

� MPASM (Assembleur) : d:\mcc18\mpasm\mpasmwin.exe 

� MPLINK (Linker) : d:\mcc18\bin\mplink.exe 

� MPLAB C18 (compilateur C) : d:\mcc18\bin\mcc18.exe 

� MPLIB (gestion des librairies) : d:\mcc18\bin\mplib.exe 

 

 

Ensuite, cliquez sur suivant. 

Dans cette nouvelle fenêtre, vous devez indiquer le nom de votre projet et l’emplacement sur le disque du 

dossier associé à ce projet (Vous pouvez utiliser le bouton Browse pour parcourir le disque et indiquer 

l’emplacement). Choisissez un nom de projet en lien avec la fonction de ce projet.  

 

 

 

Ensuite, cliquez sur suivant. 

Dans la fenêtre qui apparaît, vous devez inclure les fichiers sources de votre projet. (les fichiers contenant 

les définitions des fonctions (gamelxx_v3.c). Incluez aussi les fichiers d'en-tête des librairies (gamelxx_v3.h), 

cela facilitera l'enregistrement du projet si vous voulez le stocker dans un autre dossier. 
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Enfin, cliquez sur suivant puis terminer. 

Etape 3 : Configuration des options de compilation du projet 

La dernière étape consiste à fournir les options de compilation du projet. Sélectionnez Project>Build 

Options>Project. Entrez les chemins d’accès aux fichiers d’en-tête (d:\mcc18\h en salle de projet), aux 

librairies de MPLAB C18 (d:\mcc18\lib en salle de projet) et aux fichiers linker (d:\mcc18\lkr en salle de 

projet) comme indiqué sur la figure ci-dessous. 

 

 

 

Ajout de fichiers sources et linker au projet 

Comme tout bon programmeur, vous allez écrire des fonctions qu’il faudra compiler. La première d’entre 

elles est la fonction main( ). Les définitions de ces fonctions (appelées aussi corps des fonctions), pour être 

compilées, doivent être incluses dans le projet. 
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Pour créer un nouveau fichier, cliquez sur File>New. Ensuite, enregistrez ce fichier dans votre répertoire 

avec un nom choisi intelligemment suivi de l'extension .c pour un fichier contenant les définitions des 

fonctions (File>Save As…). Pour ajouter ce fichier source C, dans la fenêtre project (accessible par 

View>project si elle n'est pas visible), cliquez sur Source Files avec le bouton droit de la souris et 

sélectionnez Add Files. 

 

Remarque : les fichiers d’en-tête n’ont pas besoin d’être compilés. Ils sont spécifiés comme provenant du 

dossier du compilateur (#include < xxx.h >) ou du dossier du projet (#include " xxx.h "), il n’est donc pas 

nécessaire d’ajouter ceux-ci au projet. Cependant, l'ajout des fichiers d'en-tête des librairies IUT ou 

personnelles dans le projet permet de les copier automatiquement quand vous enregistrer votre projet dans 

un nouveau dossier. (cf  10.5). 

 

Le linker Mplink construit votre projet pour votre microcontrôleur, à partir des objets compilés sur la base de 

vos sources en langage C. Pour cela, il a besoin d’un script de linkage lui indiquant les disponibilités de la 

mémoire dans le microcontrôleur que vous utilisez. Sélectionnez Linker Scripts avec le bouton droit de la 

souris et Add Files. Recherchez le fichier 18f4550i.lkr dans le dossier linker de C18 (d:\mcc18\lkr en salle de 

projet) de MPLAB C18. Ce fichier linker permet de créer un projet utilisant le débogueur MPLAB ICD 2. 

 

MPLIB

MCC18

MPLINK

MCC18

main.c gameladc.c

gameladc.omain.o

math.lib

mon_projet.hex

mon_projet.mapmon_projet.cof

mon_projet.cod mon_projet.lst

p18f4550.lkr

 

 

MPLAB se présente alors de la manière suivante : 
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fenêtre
projet

fenêtre
donnant
des infos
sur les
tâches
exécutées
par MPLAB

fenêtre
éditeur

fenêtre
watch

Icône pour la connexion
de l’ICD2 et la
programmation

Icônes pour les 
opérations de 
déboguage

Point d’arrêt
breakpoint

Flèche indiquant
la prochaine
instruction 
à exécuter

 

10.2 COMPILATION ET CONSTRUCTION DU PROJET : 

Sélectionnez Project>Build All pour compiler et linker le projet. S’il existe des messages d’avertissements et 

d’erreurs, ils apparaîtront dans la fenêtre de sortie (Output). Sinon, le message BUILD SUCCEEDED apparaît 

dans cette fenêtre de sortie. Vous pouvez faire apparaître la fenêtre de sortie en cliquant sur View>Output. 

 

10.3 EXECUTION DU PROGRAMME ET DEBOGAGE AVEC MPLAB ICD 2 : 

Le débogage consiste à contrôler l'exécution d'un programme par le PC. Cela regroupe les modes pas-à-pas, 

la scrutation de variables (watch), et la mise en place de points d'arrêt (breakpoint). La liaison entre le PC et 

le microcontrôleur est cruciale pour ces actions. Elle se fait par le débogueur MPLAB ICD2. Ce débogueur 

sert aussi à envoyer le programme dans le microcontrôleur. Il est donc débogueur et programmateur. 

Lorsque votre programme ne fonctionne pas, il est indispensable que vous sachiez utiliser ces outils pour 

parvenir à retrouver l'erreur dans votre programme ou votre algorithme.  

 

Etape 1 : Sélection du débuggeur 

Sélectionnez Debugger>Select Tool>MPLAB ICD 2 pour choisir l'ICD2 comme outil de communication entre 

PC et µC. Vous devez voir apparaître la barre d'outils suivante : 
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Etape 2 : Connexion au microcontrôleur 

Pour vous connecter au microcontrôleur avec MPLAB ICD 2, sélectionnez Debugger>Connect ou sélectionnez 

l’icône  

 

La fenêtre de sortie montre que le programmeur MPLAB ICD 2 passe des tests de vérification et affiche le 

mot READY si aucune erreur ne s’est produite. 

Etape 3 : Programmation 

Pour programmer le microcontrôleur, sélectionnez Debugger>Program ou sélectionnez l’icône  

Etape 4 : Lancement du programme 

Pour lancer le programme, sélectionnez Debugger>Run, ou l’icône  

Pour lancer le programme de nouveau, sélectionnez Debugger>Reset ou l'icône  

Etape 5 : Débogage 

Pour retrouver les éventuelles erreurs de votre programme, vous devez utiliser les fonctionnalités suivantes, 

dites de débogage : 

 Halt (F5) permet de stopper l'exécution du programme. Une flèche verte vous indique alors l'instruction 

qu'allait exécuter le microcontrôleur au moment où vous l'avez stoppé. Cette fonction permet de savoir dans 

quelle boucle s'est perdu votre microcontrôleur le cas échéant. 
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 mode pas à pas 

 Step into (F7) permet de lancer l'exécution de l'instruction suivante, indiquée par la flèche verte. Si 

l'instruction est un appel de fonction, seule la première instruction de la fonction sera exécutée. 

 Step over (F8) permet de lancer l'exécution de l'instruction suivante, indiquée par la flèche verte. Si 

l'instruction est un appel de fonction, L'ensemble de la fonction sera exécuté. 

Ces deux dernières fonctions step over et step into sont très utiles pour exécuter le programme pas à pas et 

voir ainsi l'évolution des variables instruction après instruction. Cependant, même avec Step over, le 

programme s'exécute très lentement. Si vous avez des délais dans votre programme, vous risquez 

d'attendre pendant toute la séance que la boucle se termine ! 

 

 points d'arrêt 

Vous pouvez ajouter aussi des points d'arrêt dans le fichier source de votre programme en cliquant sur le 

bouton droit dans la marge à gauche puis en sélectionnant Set Breakpoint. 

Quand vous lancer le programme, il s'exécute jusqu'à ce point d'arrêt. Cela permet ainsi de n'exécuter 

qu'une partie du programme. Vous pouvez mettre autant de points d'arrêt que vous le souhaitez.  

Entre 2 points d'arrêt, le programme s'exécute à vitesse normale. Cela permet donc aisément d'aller d'un 

point à l'autre du programme regarder l'évolution des variables. 

Après un reset, vous pouvez aussi mettre un point d'arrêt au début de votre main() pour qu'il s'y arrête 

après les étapes d'initialisation. 

Semblable aux points d'arrêt, la fonction run to cursor, disponible dans le même menu contextuel permet de 

faire s'exécuter le programme jusqu'à l'endroit où est placé votre curseur. 

 

 Scrutation des variables 

Pour voir l'évolution des variables en mode pas à pas, vous pouvez au choix glisser la souris sur la variable 

ou alors utiliser les outils suivants : 

� La fenêtre Watch (View>Watch) que vous avez déjà utilisée en TP. Vous y sélectionnez les variables que 

vous souhaitez voir et cliquez sur Add Symbol. Vous pouvez aussi visualiser les registres internes du 

microcontrôleur en choisissant dans la colonne de gauche et en cliquant sur Add SFR. 
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� La fenêtre Locals (View>Locals) est souvent plus pratique car elle vous montre automatiquement toutes 

les variables locales de la fonction où est arrêté votre programme (indiquée par la flèche verte). 

 

10.4 EXECUTION DU PROGRAMME EN MODE AUTONOME 

Lorsque vous avez vérifié que votre programme fonctionne en mode connecté (avec débogueur), vous 

pouvez alors le lancer en mode autonome (sans débogueur, déconnecté du PC). 

Pour cela, vous désélectionnez le débogueur (Debugger>Select Tool>None) et sélectionnez le 

programmateur (Programmer>Select Programmer>MPLAB ICD2). Le MPLAB ICD2 sert alors uniquement à 

programmer votre microcontrôleur. 

Vous chargez le programme comme précédemment et débranchez le programmateur. Ensuite, pour relancer 

le programme, vous utiliserez le bouton reset de la carte microcontrôleur. 

10.5 QUELQUES ASTUCES 

Pour faciliter l'utilisation de MPLAB, voici quelques astuces. 

� D'abord, vous aurez remarqué que l'attribution d'une fenêtre à chaque fichier encombre vite le bureau. 

Pour éviter les courants d'air et afficher tous les fichiers dans une seule fenêtre, dans la fenêtre édition, 

cliquez sur le bouton droit et sélectionner Properties… puis cochez la case Use Tabbed Windows. 

Cette option ne sera active que lorsque vous ouvrirez MPLAB de nouveau. 

 

� Lorsque vous avez plusieurs fonctions ou plusieurs boucles imbriquées, il est intéressant de pouvoir 

afficher ou non le code de chaque boucle. Pour cela, répétez l'opération précédente (clic droit dans la zone 

d'édition) et cochez la case Enable Code Folding. 
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� Lorsque vous avez un projet qui fonctionne, il faut le conserver et créer un nouveau projet pour vos tests. 

Pour créer un nouveau projet identique au projet actuel dans un autre répertoire, cliquez sur Project>Save 

Project As… Choisissez le nouveau répertoire. MPLAB y sauvegardera alors votre projet (.mcp), votre espace 

de travail (.mcw) et tous les fichiers inclus dans votre projet (.c, .h, .lkr) 

 

� Pour vérifier la place qu'occupe votre programme dans la mémoire flash et la place nécessaire à son 

exécution en mémoire RAM, lancez View>Memory Usage Gauge. 

 

 

� Lorsque vous n'avez pas de microcontrôleur sous la main, vous pouvez utilisez le simulateur de MPLAB 

IDE. (Debugger>Select Tool>MPLAB Sim). En plus des fenêtres Locals et Watch vous avez accès à 

l'évolution des sorties du microcontrôleur par la fenêtre Logic Analyseur (View>Simulator Logic Analyseur). 

Elle permet de voir l'évolution d'une sortie. Vous pouvez aussi créer un fichier avec les entrées, etc… 

 

 

 

Il est aussi possible en simulation de simuler l'affichage de données envoyées sur la liaison série 

(Debugger>Settings>Uart1 IO). La fenêtre Output a alors un onglet pour cette liaison série SIM Uart1. 
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11 BOOTLOADER 

page réalisé à l'aide d'un fichier de M. Guinand 

Si vous amenez la carte microcontrôleur chez vous, il est possible de la 

programmer simplement sans programmateur, avec un simple câble USB A-B (le 

câble de votre imprimante par exemple). Pour cela il suffit d'installer un petit 

programme appelé bootloader en mémoire flash : 

 

Je vous conseille de copier sur un support personnel tout le répertoire 

Y:\commun\Microchip\bootloader. 

11.1 INSTALLER LE BOOTLOADER USB SUR VOTRE CARTE 

Avant de pouvoir utiliser le bootloader, il faut avoir installer ce dernier dans la mémoire de votre 

microcontrôleur à l'aide d'un programmateur ICD2. 

� Pour cela, sous MPLAB, ouvrez l'espace de travail (File>Open Workspace…) bootloader_usb.mcw présent 

dans le dossier suivant : 

y:\commun\Microchip\bootloader\bootloader_usb. 

� Programmez alors simplement le microcontrôleur. (Programmer>Program) 

Le bootloader est désormais installé sur votre carte. 

11.2 CREER UN PROJET SOUS MPLAB DESTINE A ETRE ENVOYE PAR LE BOOTLOADER 

Quelques légères modifications sont à apporter pour créer un projet destiné à être envoyé au 

microcontrôleur via le bootloader. 

� Ajoutez le fichier gamelinit_v3_bootloader.h à votre projet et incluez-le dans le main à la place du 

gamelinit_v3.h habituel. 

� Remplacez le fichier de linker p18f4550i.lkr par le fichier rm18f4550.lkr. 

Ces 2 fichiers se trouvent dans le dossier y:\...\bootloader\. 

 

Ensuite, vous pouvez compiler votre programme normalement. Si votre chemin d'accès vers le projet est 

long, vous aurez une erreur de ce type : 

MP2COD 4.06, COFF to COD File Converter 

Copyright (c) 2006 Microchip Technology Inc. 

Error - Source file 'C:\...\test1_bootloader.c' name exceeds file format maximum of 62 characters. 

Errors    : 1 

Cette erreur empêche la génération du fichier .hex que nous enverrons ensuite par le bootloader. Elle est 

due à un ancien format de fichier (.cod) qui ne supportait pas les chemins à rallonge. Ce fichier étant inutile, 

nous allons supprimer sa génération (Project>Build Options>Project>MPLINK linker>Supress Code File 

generation) 

Bootloader

0

2 Ko

32Ko

mémoire disponible pour
votre programme
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Vous pouvez alors recompiler et vérifier que MPLAB a bien créé un fichier mon_projet.hex dans le dossier du 

projet. 

11.3 CHARGEZ LE PROGRAMME SUR LA CARTE 

La dernière étape consiste à envoyer le programme sur la carte. 

� Branchez le cordon USB (qui peut aussi alimenter la carte) au PC et à la carte. Appuyez sur les boutons 

reset et BP1 en même temps puis relâchez le reset. La carte, voyant le bouton BP1 enfoncé dès le 

démarrage passe en mode bootloader USB et tente de se connecter au PC. 

� Donnez à votre PC qui les réclame les drivers présents dans le dossier Y:\...\Bootloader USB Driver. 

� Lancez le programme PDFSUSB.exe présent dans le dossier Y:\...\BootLoader USB Prog. et dans l'onglet 

"Bootload Mode", sélectionner la carte détectée. 

 

� Chargez le fichier "HEX" de votre programme. (présent dans le dossier du projet normalement) 

� Programmez la carte (Program Device) et appuyez sur RESET (bouton rouge) pour démarrer le 

programme. 

Pour programmer la carte de nouveau, il suffit d'appuyer de nouveau sur les boutons Reset et BP1 et de 

relâcher RESET d'abord. 
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12 DOCUMENTATION 

Dans le répertoire Y:\commun\Microchip\documentation, vous trouverez des documents à propos de la 

programmation de la carte microcontrôleur GamelTrophy. 

 

Documents IUT 

� Guide de mise en œuvre : c'est le présent document. 

� automates.pdf : cours sur les automates (machines à état) de Jacques Weber. 

� automates_c.pdf : exercices corrigés sur les automates de Jacques Weber. 

 

Documents Microchip sur les outils 

� MPLAB_IDE_quick_start_guide.pdf est un guide d'apprentissage rapide de MPLAB IDE 

� MPLAB_IDE_user_guide.pdf est le guide d’utilisation de MPLAB IDE 

� MPLAB_C18_GettingStarted.pdf est un guide d'apprentissage rapide de C18 Compiler 

� MPLAB_C18_Userguide.pdf est le guide d'utilisation de C18 compiler 

� MPLAB_C18_Libraries.pdf est le guide d'utilisation des librairies de C18 compiler 

� C18_config_settings.pdf est la liste des valeurs possibles pour les registres de configuration 

 

Documents Microchip sur le PIC18F4550 

� PIC18F4550.pdf est la datasheet du microcontrôleur PIC18F4550 

 

Vous trouverez aussi dans ce répertoire tous les outils et toutes les librairies pour programmer la carte 

microcontrôleur GamelTrophy. 

 

Vous trouverez une mine d’informations sur les microcontrôleurs et leur programmation sur le site de 

Microchip : www.microchip.com. 
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AIDE MEMOIRE 

 

Configuration du microcontrôleur 

en en-tête du fichier principal  

#include <p18f4550.h>    // ce fichier contient les adresses des différents périphériques du µC. 

#include "gamelinit_v3.h"  // ce fichier contient un partie de la configuration du µC. 

 

Prototypes des différentes fonctions 

bibliothèque gamelcd_v3 

void lcd_init(void) 

void lcd_gotoyx(char y, char x) 

void lcd_puti(int nombre) 

void lcd_putc(char lettre) 

void lcd_puts(char* message) 

void lcd_putrs(const rom char *message); 
 
bibliothèque gameladc_v3 

void adc_init(char numero_lastchannel_used) 

int adc_read(char numero_channel) 

 

bibliothèque gamelpwm_v3 

void pwm_init(char period, char nb_canaux) 

void pwm_setdc1(unsigned int dutycycle1) 

void pwm_setdc2(unsigned int dutycycle2) 

 

Pour utiliser el bootloader 

#include "gamelinit_v3_bootloader.h"  à la place de gamelinit_v3.h. 

inclure le fichier rm18f4550.lkr au projet. 

Raccourcis clavier 

Build All  Ctrl+F10 

Reset   F6 

Run   F9 

Halt   F5 

Step into  F7 

Step Over  F8 


